summaryrefslogtreecommitdiffstats
path: root/package/libsigsegv
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2013-11-05 07:43:29 +0000
committerPeter Korsgaard <peter@korsgaard.com>2013-11-05 08:58:10 +0100
commitc6e69598a3e801267d23f3e29a030b1ea13878c5 (patch)
tree80d455b40bb473e8c81cb39656cae748ca25d7f2 /package/libsigsegv
parent602bbb73430d95e53b6f64ab95a61f0a032e6d81 (diff)
downloadbuildroot-c6e69598a3e801267d23f3e29a030b1ea13878c5.tar.gz
buildroot-c6e69598a3e801267d23f3e29a030b1ea13878c5.zip
libsigsegv: fix avr32 build
The libsigsegv configure step fails to correctly figure out the direction of stack growth for avr32. This leads to a zero STACK_DIRECTION definition, and build failures such as the following. http://autobuild.buildroot.net/results/a3fe938f9376533b4777d79deb7a2ee83ed5ce33 Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libsigsegv')
-rw-r--r--package/libsigsegv/libsigsegv-0001-fix-avr32-build.patch20
-rw-r--r--package/libsigsegv/libsigsegv.mk2
2 files changed, 22 insertions, 0 deletions
diff --git a/package/libsigsegv/libsigsegv-0001-fix-avr32-build.patch b/package/libsigsegv/libsigsegv-0001-fix-avr32-build.patch
new file mode 100644
index 0000000000..f5857649a9
--- /dev/null
+++ b/package/libsigsegv/libsigsegv-0001-fix-avr32-build.patch
@@ -0,0 +1,20 @@
+The libsigsegv configure step fails to correctly figure out the direction of
+stack growth for avr32. This leads to a zero STACK_DIRECTION definition, and
+build failures such as the following.
+
+ http://autobuild.buildroot.net/results/a3fe938f9376533b4777d79deb7a2ee83ed5ce33
+
+Signed-off-by: Simon Dawson <spdawson@gmail.com>
+
+diff -Nurp a/m4/stack-direction.m4 b/m4/stack-direction.m4
+--- a/m4/stack-direction.m4 2009-11-21 12:22:45.000000000 +0000
++++ b/m4/stack-direction.m4 2013-11-04 09:29:27.558036038 +0000
+@@ -16,7 +16,7 @@ AC_DEFUN([SV_STACK_DIRECTION],
+ alpha* | \
+ arc | \
+ arm* | strongarm* | xscale* | \
+- avr | \
++ avr | avr32 | \
+ c1 | c2 | c32 | c34 | c38 | \
+ clipper | \
+ cris | \
diff --git a/package/libsigsegv/libsigsegv.mk b/package/libsigsegv/libsigsegv.mk
index 2cc2544c01..a5bb31c9cf 100644
--- a/package/libsigsegv/libsigsegv.mk
+++ b/package/libsigsegv/libsigsegv.mk
@@ -11,4 +11,6 @@ LIBSIGSEGV_CONF_ENV = sv_cv_fault_posix=yes
LIBSIGSEGV_LICENSE = GPLv2+
LIBSIGSEGV_LICENSE_FILES = COPYING
+LIBSIGSEGV_AUTORECONF = YES
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud