summaryrefslogtreecommitdiffstats
path: root/package/libnftnl/libnftnl.mk
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2014-01-23 15:00:02 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-27 22:11:38 +0100
commit44092444554ab65c721cfdc35f3558dcafebb082 (patch)
treebf8397de1f5e0de3e0147928182fda81dbfb11a5 /package/libnftnl/libnftnl.mk
parent9eefa845a2617333318a59d767fa61363a39e4cf (diff)
downloadbuildroot-44092444554ab65c721cfdc35f3558dcafebb082.tar.gz
buildroot-44092444554ab65c721cfdc35f3558dcafebb082.zip
libnftnl: add JSON and XML parsing support
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libnftnl/libnftnl.mk')
-rw-r--r--package/libnftnl/libnftnl.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/libnftnl/libnftnl.mk b/package/libnftnl/libnftnl.mk
index 5eba0aa800..0aecf1244b 100644
--- a/package/libnftnl/libnftnl.mk
+++ b/package/libnftnl/libnftnl.mk
@@ -12,4 +12,18 @@ LIBNFTNL_LICENSE_FILES = COPYING
LIBNFTNL_INSTALL_STAGING = YES
LIBNFTNL_DEPENDENCIES = host-pkgconf libmnl
+ifeq ($(BR2_PACKAGE_LIBNFTNL_JSON),y)
+LIBNFTNL_CONF_OPT += --with-json-parsing
+LIBNFTNL_DEPENDENCIES += jansson
+else
+LIBNFTNL_CONF_OPT += --without-json-parsing
+endif
+
+ifeq ($(BR2_PACKAGE_LIBNFTNL_XML),y)
+LIBNFTNL_CONF_OPT += --with-xml-parsing
+LIBNFTNL_DEPENDENCIES += mxml
+else
+LIBNFTNL_CONF_OPT += --without-xml-parsing
+endif
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud