summaryrefslogtreecommitdiffstats
path: root/package/libldns/libldns.mk
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-08-29 12:53:38 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-29 14:56:33 +0200
commit721c78c9e05a49a3291364283225b552debb879e (patch)
treeb26de9942abe35ce4fc4b3cf923e5b2a3538dbec /package/libldns/libldns.mk
parent5dc0167525bdbbd14e554a60a52ac9fe78d00ce9 (diff)
downloadbuildroot-721c78c9e05a49a3291364283225b552debb879e.tar.gz
buildroot-721c78c9e05a49a3291364283225b552debb879e.zip
package/libldns: new package
Needed by freeswitch. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libldns/libldns.mk')
-rw-r--r--package/libldns/libldns.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/libldns/libldns.mk b/package/libldns/libldns.mk
new file mode 100644
index 0000000000..9a284040ea
--- /dev/null
+++ b/package/libldns/libldns.mk
@@ -0,0 +1,36 @@
+################################################################################
+#
+# libldns
+#
+################################################################################
+
+LIBLDNS_VERSION = 1.6.17
+LIBLDNS_SOURCE = ldns-$(LIBLDNS_VERSION).tar.gz
+LIBLDNS_SITE = http://www.nlnetlabs.nl/downloads/ldns
+LIBLDNS_LICENSE = BSD-3c
+LIBLDNS_LICENSE_FILES = LICENSE
+LIBLDNS_INSTALL_STAGING = YES
+LIBLDNS_CONF_OPTS = \
+ --without-examples \
+ --without-p5-dns-ldns \
+ --without-pyldns \
+ --without-pyldnsx
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBLDNS_DEPENDENCIES += host-pkgconf openssl
+LIBLDNS_CONF_OPTS += \
+ --with-ssl=$(STAGING_DIR)/usr \
+ --enable-dane \
+ --enable-ecdsa \
+ --enable-gost \
+ --enable-sha2
+else
+LIBLDNS_CONF_OPTS += \
+ --without-ssl \
+ --disable-dane \
+ --disable-ecdsa \
+ --disable-gost \
+ --disable-sha2
+endif
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud