summaryrefslogtreecommitdiffstats
path: root/package/imx-usb-loader
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-05-02 13:14:29 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-05-02 13:24:42 +0200
commit7e8e3e8209edad816e149612d419a7ec14241676 (patch)
tree30a3520f104893c630cb15c5dbd510e61b719c7f /package/imx-usb-loader
parent2acb231eaec310f80980e3f1d0eccb4136bf02f2 (diff)
downloadbuildroot-7e8e3e8209edad816e149612d419a7ec14241676.tar.gz
buildroot-7e8e3e8209edad816e149612d419a7ec14241676.zip
imx-usb-loader: cleanup
HOST_CONFIGURE_OPTS is a superset of HOST_MAKE_ENV, so there is no need to pass them both. Also use HOST_CONFIGURE_OPTS for the install step for consistency, and finally, add host-pkgconf to _DEPENDENCIES as it is explicitly used (currently gets pulled in by host-libusb though). Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/imx-usb-loader')
-rw-r--r--package/imx-usb-loader/imx-usb-loader.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/imx-usb-loader/imx-usb-loader.mk b/package/imx-usb-loader/imx-usb-loader.mk
index fdabb6af30..280ffc0401 100644
--- a/package/imx-usb-loader/imx-usb-loader.mk
+++ b/package/imx-usb-loader/imx-usb-loader.mk
@@ -8,14 +8,14 @@ IMX_USB_LOADER_VERSION = f96aee286ea17c832b7ec922dd76842deb5ce299
IMX_USB_LOADER_SITE = $(call github,boundarydevices,imx_usb_loader,$(IMX_USB_LOADER_VERSION))
IMX_USB_LOADER_LICENSE = LGPLv2.1+
IMX_USB_LOADER_LICENSE_FILES = COPYING
-IMX_USB_LOADER_DEPENDENCIES = host-libusb
+IMX_USB_LOADER_DEPENDENCIES = host-libusb host-pkgconf
define HOST_IMX_USB_LOADER_BUILD_CMDS
- $(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+ $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)
endef
define HOST_IMX_USB_LOADER_INSTALL_CMDS
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D) \
+ $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
DESTDIR=$(HOST_DIR) sysconfdir=/etc install
endef
OpenPOWER on IntegriCloud