summaryrefslogtreecommitdiffstats
path: root/package/glibc/glibc.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-10-08 20:17:06 +0200
committerPeter Korsgaard <peter@korsgaard.com>2013-10-09 15:15:06 +0200
commit186a99b1c6562da724a5500190835c709d152df4 (patch)
tree823fec48f97e7da2b539a8f3491ac95f20a0fd90 /package/glibc/glibc.mk
parent36ef1b4494f669d9c6f8507fb912f83f46a2d63d (diff)
downloadbuildroot-186a99b1c6562da724a5500190835c709d152df4.tar.gz
buildroot-186a99b1c6562da724a5500190835c709d152df4.zip
toolchain: modify the wildcard logic for shared libraries copying
Until now, the copy_toolchain_lib_root function took as argument the base name of a library (e.g: libm.so), and was assuming that the usual scheme libm.so.<x> being a symbolic link to the real library was used. However, with musl based toolchains, the C library is named libc.so directly, with no symbolic link at all. Therefore, this commit changes the copy_toolchain_lib_root to move the responsibility of using a wildcard or not after the library name the caller's responsibility. So, all the existing LIB_EXTERNAL_LIBS values are modified to have a .* at the end, so that the behavior is effectively unchanged. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/glibc/glibc.mk')
-rw-r--r--package/glibc/glibc.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
index 4d89caff02..0dab4926a3 100644
--- a/package/glibc/glibc.mk
+++ b/package/glibc/glibc.mk
@@ -112,12 +112,12 @@ endef
#
GLIBC_LIBS_LIB = \
- ld*.so libc.so libcrypt.so libdl.so libgcc_s.so libm.so \
- libnsl.so libpthread.so libresolv.so librt.so libutil.so \
- libnss_files.so libnss_dns.so
+ ld*.so.* libc.so.* libcrypt.so.* libdl.so.* libgcc_s.so.* libm.so.* \
+ libnsl.so.* libpthread.so.* libresolv.so.* librt.so.* libutil.so.* \
+ libnss_files.so.* libnss_dns.so.*
ifeq ($(BR2_PACKAGE_GDB_SERVER),y)
-GLIBC_LIBS_LIB += libthread_db.so
+GLIBC_LIBS_LIB += libthread_db.so.*
endif
define GLIBC_INSTALL_TARGET_CMDS
OpenPOWER on IntegriCloud