summaryrefslogtreecommitdiffstats
path: root/package/eudev
diff options
context:
space:
mode:
authoreric.le.bihan.dev@free.fr <eric.le.bihan.dev@free.fr>2014-02-07 14:21:32 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-12 22:14:16 +0100
commit937a95449ecaad02386523f8fe2eeefbea6be971 (patch)
tree40dfdc3d36d1f1fe4b384c8492d3e47c6c60dc14 /package/eudev
parent9b8ffcd8f25cede33bcd2dc81ef8682c2acb0b97 (diff)
downloadbuildroot-937a95449ecaad02386523f8fe2eeefbea6be971.tar.gz
buildroot-937a95449ecaad02386523f8fe2eeefbea6be971.zip
eudev: new package
eudev is a userspace device management daemon. It is a standalone version, independent from systemd. It is a fork maintained by Gentoo. Features: - No extra configuration options are available: Gudev is build if libglib2 is selected. - No dependency on hwdata as the package uses its own hardware database (as does systemd). eudev 1.3 is in sync with systemd v207. [Peter: add BR2_USE_MMU dependency] Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/eudev')
-rw-r--r--package/eudev/Config.in38
-rwxr-xr-xpackage/eudev/S10udev48
-rw-r--r--package/eudev/eudev.mk43
3 files changed, 129 insertions, 0 deletions
diff --git a/package/eudev/Config.in b/package/eudev/Config.in
new file mode 100644
index 0000000000..9d2eb1b285
--- /dev/null
+++ b/package/eudev/Config.in
@@ -0,0 +1,38 @@
+config BR2_PACKAGE_EUDEV
+ bool "eudev"
+ depends on !BR2_avr32 # no epoll_create1
+ depends on BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV
+ depends on BR2_USE_MMU # uses fork()
+ depends on BR2_LARGEFILE # util-linux
+ depends on BR2_USE_WCHAR # util-linux
+ depends on !BR2_PREFER_STATIC_LIB # kmod
+ select BR2_PACKAGE_UTIL_LINUX
+ select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
+ select BR2_PACKAGE_KMOD
+ help
+ Userspace device daemon. This is a standalone version,
+ independent of systemd. It is a fork maintained by Gentoo.
+
+ eudev requires a Linux kernel >= 2.6.34: it relies on devtmpfs
+ and inotify.
+
+ http://github.com/gentoo/eudev/
+
+if BR2_PACKAGE_EUDEV
+
+config BR2_PACKAGE_EUDEV_RULES_GEN
+ bool "enable rules generator"
+ help
+ Enable persistent rules generator
+
+endif
+
+comment "eudev needs eudev /dev management"
+ depends on !BR2_avr32
+ depends on BR2_USE_MMU
+ depends on !BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV
+
+comment "eudev needs a toolchain w/ largefile, wchar, dynamic library"
+ depends on !BR2_avr32
+ depends on BR2_USE_MMU
+ depends on !BR2_LARGEFILE || !BR2_USE_WCHAR || BR2_PREFER_STATIC_LIB
diff --git a/package/eudev/S10udev b/package/eudev/S10udev
new file mode 100755
index 0000000000..e4d28a2323
--- /dev/null
+++ b/package/eudev/S10udev
@@ -0,0 +1,48 @@
+#!/bin/sh
+#
+# udev This is a minimal non-LSB version of a UDEV startup script. It
+# was derived by stripping down the udev-058 LSB version for use
+# with buildroot on embedded hardware using Linux 2.6.34+ kernels.
+#
+# You may need to customize this for your system's resource limits
+# (including startup time!) and administration. For example, if
+# your early userspace has a custom initramfs or initrd you might
+# need /dev much earlier; or without hotpluggable busses (like USB,
+# PCMCIA, MMC/SD, and so on) your /dev might be static after boot.
+#
+# This script assumes your system boots right into the eventual root
+# filesystem, and that init runs this udev script before any programs
+# needing more device nodes than the bare-bones set -- /dev/console,
+# /dev/zero, /dev/null -- that's needed to boot and run this script.
+#
+
+# Check for missing binaries
+UDEV_BIN=/sbin/udevd
+test -x $UDEV_BIN || exit 5
+
+# Check for config file and read it
+UDEV_CONFIG=/etc/udev/udev.conf
+test -r $UDEV_CONFIG || exit 6
+. $UDEV_CONFIG
+
+case "$1" in
+ start)
+ echo -n "Populating ${udev_root:-/dev} using udev: "
+ echo -e '\000\000\000\000' > /proc/sys/kernel/hotplug
+ $UDEV_BIN -d || (echo "FAIL" && exit 1)
+ udevadm trigger
+ echo "done"
+ ;;
+ stop)
+ # Stop execution of events
+ udevadm control --stop-exec-queue
+ killall udevd
+ ;;
+ *)
+ echo "Usage: $0 {start|stop}"
+ exit 1
+ ;;
+esac
+
+
+exit 0
diff --git a/package/eudev/eudev.mk b/package/eudev/eudev.mk
new file mode 100644
index 0000000000..ffa413f3ad
--- /dev/null
+++ b/package/eudev/eudev.mk
@@ -0,0 +1,43 @@
+################################################################################
+#
+# eudev
+#
+################################################################################
+
+EUDEV_VERSION = 1.3
+EUDEV_SITE = $(call github,gentoo,eudev,v$(EUDEV_VERSION))
+EUDEV_LICENSE = GPLv2+ (programs), LGPLv2.1+ (libraries)
+EUDEV_LICENSE_FILES = COPYING
+EUDEV_INSTALL_STAGING = YES
+EUDEV_AUTORECONF = YES
+
+# mq_getattr is in librt
+EUDEV_CONF_ENV += LIBS=-lrt
+
+EUDEV_CONF_OPT = \
+ --sbindir=/sbin \
+ --with-rootlibdir=/lib \
+ --libexecdir=/lib \
+ --with-firmware-path=/lib/firmware \
+ --disable-introspection \
+ --enable-split-usr \
+ --enable-libkmod
+
+EUDEV_DEPENDENCIES = host-gperf host-pkgconf util-linux kmod
+
+ifeq ($(BR2_PACKAGE_EUDEV_RULES_GEN),y)
+EUDEV_CONF_OPT += --enable-rule_generator
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+EUDEV_CONF_OPT += --enable-gudev
+EUDEV_DEPENDENCIES += libglib2
+else
+EUDEV_CONF_OPT += --disable-gudev
+endif
+
+define EUDEV_INSTALL_INIT_SYSV
+ $(INSTALL) -m 0755 package/eudev/S10udev $(TARGET_DIR)/etc/init.d/S10udev
+endef
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud