summaryrefslogtreecommitdiffstats
path: root/package/eigen
diff options
context:
space:
mode:
authorDavide Viti <zinosat@tiscali.it>2014-03-31 00:30:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-03 21:49:20 +0200
commitfeefe6b8843740562067625aaf3ca3b639502afc (patch)
treef96b08c403127fe065941c4ce7422351b0beeaff /package/eigen
parentb439a9f11d798c7425d1253a30cf2083dccabfcf (diff)
downloadbuildroot-feefe6b8843740562067625aaf3ca3b639502afc.tar.gz
buildroot-feefe6b8843740562067625aaf3ca3b639502afc.zip
eigen: add an option to install unsupported modules
Signed-off-by: Davide Viti <d.viti@infosolution.it> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/eigen')
-rw-r--r--package/eigen/Config.in8
-rw-r--r--package/eigen/eigen.mk8
2 files changed, 16 insertions, 0 deletions
diff --git a/package/eigen/Config.in b/package/eigen/Config.in
index e94f9a3e0b..03d65b19d1 100644
--- a/package/eigen/Config.in
+++ b/package/eigen/Config.in
@@ -13,5 +13,13 @@ config BR2_PACKAGE_EIGEN
http://eigen.tuxfamily.org/
+if BR2_PACKAGE_EIGEN
+
+config BR2_PACKAGE_EIGEN_UNSUPPORTED_MODULES
+ bool "unsupported modules"
+ help
+ Install eigen unsupported modules
+endif
+
comment "eigen needs a toolchain w/ C++"
depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/eigen/eigen.mk b/package/eigen/eigen.mk
index 9a5ce7dfb9..7fd318748d 100644
--- a/package/eigen/eigen.mk
+++ b/package/eigen/eigen.mk
@@ -14,12 +14,20 @@ EIGEN_INSTALL_STAGING = YES
EIGEN_INSTALL_TARGET = NO
EIGEN_DEST_DIR = $(STAGING_DIR)/usr/include/eigen3
+ifeq ($(BR2_PACKAGE_EIGEN_UNSUPPORTED_MODULES),y)
+define EIGEN_INSTALL_UNSUPPORTED_MODULES_CMDS
+ mkdir -p $(EIGEN_DEST_DIR)/unsupported
+ cp -a $(@D)/unsupported/Eigen $(EIGEN_DEST_DIR)/unsupported
+endef
+endif
+
# This package only consists of headers that need to be
# copied over to the sysroot for compile time use
define EIGEN_INSTALL_STAGING_CMDS
$(RM) -r $(EIGEN_DEST_DIR)
mkdir -p $(EIGEN_DEST_DIR)
cp -a $(@D)/Eigen $(EIGEN_DEST_DIR)
+ $(EIGEN_INSTALL_UNSUPPORTED_MODULES_CMDS)
endef
$(eval $(generic-package))
OpenPOWER on IntegriCloud