summaryrefslogtreecommitdiffstats
path: root/package/directfb/directfb.mk
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2014-09-12 17:50:10 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-13 09:22:27 +0200
commitdaf4820c8527c54dfbc44d4982ad04dff9650e04 (patch)
tree4963818626c78a835ce3f8682181a46dba62f218 /package/directfb/directfb.mk
parentefba6339b5211c1e2c1a3888509e6f020f385c76 (diff)
downloadbuildroot-daf4820c8527c54dfbc44d4982ad04dff9650e04.tar.gz
buildroot-daf4820c8527c54dfbc44d4982ad04dff9650e04.zip
directfb: allow SVG support
DirectFB SVG support rely on Cairo and Cairo depends on DirectFB. Since Cairo DirectFB backend is marked as experimental, this patch choose to disable this backend when DirectFB SVG support is enable. In add, this patch may solve some tricky situations between DirectFB and Cairo (see http://sysmic.org/~jezz/results/c2f11fc0) and improve build reproducibility. [Peter: propagate atomics dependency, needs libsvg-cairo, add cairo includes] Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/directfb/directfb.mk')
-rw-r--r--package/directfb/directfb.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index 3ae7f3e9f2..32144ec299 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -116,6 +116,15 @@ else
DIRECTFB_CONF_OPT += --disable-jpeg
endif
+ifeq ($(BR2_PACKAGE_DIRECTFB_SVG),y)
+DIRECTFB_CONF_OPT += --enable-svg
+# needs some help to find cairo includes
+DIRECTFB_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/cairo"
+DIRECTFB_DEPENDENCIES += libsvg-cairo
+else
+DIRECTFB_CONF_OPT += --disable-svg
+endif
+
ifeq ($(BR2_PACKAGE_DIRECTFB_IMLIB2),y)
DIRECTFB_CONF_OPT += --enable-imlib2
DIRECTFB_DEPENDENCIES += imlib2
OpenPOWER on IntegriCloud