summaryrefslogtreecommitdiffstats
path: root/package/boost
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-12-05 15:35:46 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-12-05 15:38:05 +0100
commit9fbeea741aa511595d762a5567f9b6d27093ab61 (patch)
tree73edb78000eb3a4e1a7d0b1f8205bc93be2f3fb2 /package/boost
parent7c35f31552b2259c9b60e081e4a317acc9a6e4fc (diff)
downloadbuildroot-9fbeea741aa511595d762a5567f9b6d27093ab61.tar.gz
buildroot-9fbeea741aa511595d762a5567f9b6d27093ab61.zip
boost: add target build step
The build step for the target was missing, causing the compilation to happen during the staging install step. Add a dedicated build step like we do for the host build. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/boost')
-rw-r--r--package/boost/boost.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index b96969d662..6a2e925cb3 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -128,6 +128,14 @@ define BOOST_CONFIGURE_CMDS
echo "" >> $(@D)/user-config.jam
endef
+define BOOST_BUILD_CMDS
+ (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -q \
+ --user-config=$(@D)/user-config.jam \
+ $(BOOST_OPTS) \
+ --ignore-site-config \
+ --layout=$(BOOST_LAYOUT))
+endef
+
define BOOST_INSTALL_TARGET_CMDS
(cd $(@D) && ./b2 -j$(PARALLEL_JOBS) -q \
--user-config=$(@D)/user-config.jam \
OpenPOWER on IntegriCloud