summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2013-09-02 22:07:55 +0200
committerPeter Korsgaard <peter@korsgaard.com>2013-10-27 08:08:47 +0100
commitf2c2193b0571c2f15a430edf5c179b20914d0a95 (patch)
treef599bc19a656baa3750f15b4158cebf97a1adeee /boot
parent63ecded2e383b2bb7569e70f311580095b166e29 (diff)
downloadbuildroot-f2c2193b0571c2f15a430edf5c179b20914d0a95.tar.gz
buildroot-f2c2193b0571c2f15a430edf5c179b20914d0a95.zip
u-boot: add support for custom Mercurial repository
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/Config.in23
-rw-r--r--boot/uboot/uboot.mk5
2 files changed, 20 insertions, 8 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 88c076dd70..8e71886e22 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -31,6 +31,9 @@ config BR2_TARGET_UBOOT_CUSTOM_TARBALL
config BR2_TARGET_UBOOT_CUSTOM_GIT
bool "Custom Git repository"
+config BR2_TARGET_UBOOT_CUSTOM_HG
+ bool "Custom Mercurial repository"
+
endchoice
config BR2_TARGET_UBOOT_CUSTOM_VERSION_VALUE
@@ -47,9 +50,11 @@ endif
config BR2_TARGET_UBOOT_VERSION
string
default "2013.10" if BR2_TARGET_UBOOT_LATEST_VERSION
- default BR2_TARGET_UBOOT_CUSTOM_VERSION_VALUE if BR2_TARGET_UBOOT_CUSTOM_VERSION
+ default BR2_TARGET_UBOOT_CUSTOM_VERSION_VALUE \
+ if BR2_TARGET_UBOOT_CUSTOM_VERSION
default "custom" if BR2_TARGET_UBOOT_CUSTOM_TARBALL
- default BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION if BR2_TARGET_UBOOT_CUSTOM_GIT
+ default BR2_TARGET_UBOOT_CUSTOM_REPO_VERSION \
+ if BR2_TARGET_UBOOT_CUSTOM_GIT || BR2_TARGET_UBOOT_CUSTOM_HG
config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
string "custom patch dir"
@@ -60,13 +65,17 @@ config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
Most users may leave this empty
-if BR2_TARGET_UBOOT_CUSTOM_GIT
+if BR2_TARGET_UBOOT_CUSTOM_GIT || BR2_TARGET_UBOOT_CUSTOM_HG
-config BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL
- string "URL of custom Git repository"
+config BR2_TARGET_UBOOT_CUSTOM_REPO_URL
+ string "URL of custom repository"
+ default BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL \
+ if BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL != "" # legacy
-config BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION
- string "Custom Git version"
+config BR2_TARGET_UBOOT_CUSTOM_REPO_VERSION
+ string "Custom repository version"
+ default BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION \
+ if BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION != "" # legacy
endif
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index dc8e26f399..06b75eddeb 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -18,8 +18,11 @@ UBOOT_TARBALL = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION))
UBOOT_SITE = $(patsubst %/,%,$(dir $(UBOOT_TARBALL)))
UBOOT_SOURCE = $(notdir $(UBOOT_TARBALL))
else ifeq ($(BR2_TARGET_UBOOT_CUSTOM_GIT),y)
-UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL))
+UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_REPO_URL))
UBOOT_SITE_METHOD = git
+else ifeq ($(BR2_TARGET_UBOOT_CUSTOM_HG),y)
+UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_REPO_URL))
+UBOOT_SITE_METHOD = hg
else
# Handle stable official U-Boot versions
UBOOT_SITE = ftp://ftp.denx.de/pub/u-boot
OpenPOWER on IntegriCloud