summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
authorJames Balean <james@balean.com.au>2017-04-04 22:45:51 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-04-05 22:29:23 +0200
commit4f50f4928ca3855d9d1b1b9699d2cb37e4ca65da (patch)
treef90b9b860afb0b897eb1ca424308217e425727d8 /boot/uboot
parent4b2440b7dcc68369548c0f2be6984fe645fc6bb0 (diff)
downloadbuildroot-4f50f4928ca3855d9d1b1b9699d2cb37e4ca65da.tar.gz
buildroot-4f50f4928ca3855d9d1b1b9699d2cb37e4ca65da.zip
Add out-of-source U-Boot device tree support
Similaly to Linux, this patch adds the ability to copy in and build out-of-source device tree sources during a U-Boot build. Signed-off-by: James Balean <james@balean.com.au> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in14
-rw-r--r--boot/uboot/uboot.mk3
2 files changed, 17 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index c33861bac6..004f9c0ff0 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -407,4 +407,18 @@ config BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT
endif # BR2_TARGET_UBOOT_ENVIMAGE
+if BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG
+
+config BR2_TARGET_UBOOT_CUSTOM_DTS_PATH
+ string "Device Tree Source file paths"
+ help
+ Space-separated list of paths to device tree source files
+ that will be copied to arch/ARCH/dts/ before starting the
+ build.
+
+ To use this device tree source file, the U-Boot configuration
+ file must refer to it.
+
+endif
+
endif # BR2_TARGET_UBOOT
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index aac692c47f..1d464d9675 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -195,6 +195,9 @@ endef
endif # BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY
define UBOOT_BUILD_CMDS
+ $(if $(BR2_TARGET_UBOOT_CUSTOM_DTS_PATH),
+ cp -f $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_DTS_PATH)) $(@D)/arch/$(UBOOT_ARCH)/dts/
+ )
$(TARGET_CONFIGURE_OPTS) \
$(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
$(UBOOT_MAKE_TARGET)
OpenPOWER on IntegriCloud