summaryrefslogtreecommitdiffstats
path: root/arch
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-07-09 05:21:56 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-09 15:41:51 +0200
commitb3b60706221d75f3a0fce2441ce7a968981e7363 (patch)
tree365ac9f1b4a2ab4262ba7116d5fb59228afe52c8 /arch
parent15a96d1aaad32434bd63918ebdc09dd6468c630f (diff)
downloadbuildroot-b3b60706221d75f3a0fce2441ce7a968981e7363.tar.gz
buildroot-b3b60706221d75f3a0fce2441ce7a968981e7363.zip
arch/xtensa: allow specifying path to tarball file
currently, specifying a custom Xtrensa core is done with two variables: - the core name - the directory containing the overlay tarball However, the core name only serves to construct the tarball name, and is not used whatsoever to configure any of the toolchain components (binutils, gcc or gdb), except through the files that are overlayed in their respective source trees. This has two main drawbacks: - the overlay file must be named after the core, - the tarball can not be compressed. Furthermore, it also makes it extremely complex to implement a download of that tarball. So, those two variables can be squeezed into a single variable, that is the complete path of the overlay tarball. Update the qemu-xtensa defconfig accordingly. Note: we do not add a legacy entry for BR2_XTENSA_CORE_NAME, since it was previously a blind option in the last release, and there's been no release since we removed BR2_XTENSA_CUSTOM_NAME. So, we just update the legacy comments for BR2_XTENSA_CUSTOM_NAME, since that's all the user could have seen in any of our releases so far. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Max Filippov <jcmvbkbc@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'arch')
-rw-r--r--arch/Config.in.xtensa19
-rw-r--r--arch/arch.mk.xtensa17
2 files changed, 15 insertions, 21 deletions
diff --git a/arch/Config.in.xtensa b/arch/Config.in.xtensa
index 00b1f6853c..5d5bcb48f9 100644
--- a/arch/Config.in.xtensa
+++ b/arch/Config.in.xtensa
@@ -13,24 +13,21 @@ config BR2_xtensa_fsf
endchoice
-config BR2_XTENSA_CORE_NAME
- string "Custom Xtensa processor configuration name" if BR2_XTENSA_CUSTOM
- default BR2_XTENSA_CUSTOM_NAME if BR2_XTENSA_CUSTOM_NAME != "" # legacy
- help
- Name given to a custom Xtensa processor configuration.
-
-config BR2_XTENSA_OVERLAY_DIR
- string "Overlay directory for custom configuration"
+config BR2_XTENSA_OVERLAY_FILE
+ string "Overlay file for custom configuration"
depends on BR2_XTENSA_CUSTOM
help
- Provide the directory path that contains the overlay file
- for a custom processor configuration. The path is relative
- to the top directory of buildroot.
+ Enter the path to the overlay tarball for a custom processor
+ configuration.
+
These overlay files are tar packages with updated configuration
files for various toolchain packages and Xtensa processor
configurations. They are provided by the processor vendor or
directly from Tensilica.
+ The path can be either absolute, or relative to the top directory
+ of buildroot.
+
choice
prompt "Target Architecture Endianness"
depends on BR2_XTENSA_CUSTOM
diff --git a/arch/arch.mk.xtensa b/arch/arch.mk.xtensa
index 2843333b58..6d9fd63d12 100644
--- a/arch/arch.mk.xtensa
+++ b/arch/arch.mk.xtensa
@@ -1,18 +1,15 @@
################################################################################
-# Those two variables can be used by packages that need to extract the overlay.
+# This variable can be used by packages that need to extract the overlay.
#
-# ARCH_XTENSA_CORE_NAME is the name of the Xtensa core; empty if none or the
-# standard 'fsf' core.
-# ARCH_XTENSA_OVERLAY_TAR is the path to the overlay tarball; only valid when
-# ARCH_XTENSA_CORE_NAME is not empty.
+# ARCH_XTENSA_OVERLAY_FILE is the path to the overlay tarball; empty if not
+# using any overlay
#
# Example:
-# ifneq ($(ARCH_XTENSA_CORE_NAME),)
-# tar xf $(ARCH_XTENSA_OVERLAY_TAR) -C $(@D) --strip-components=1 gcc
+# ifneq ($(ARCH_XTENSA_OVERLAY_FILE),)
+# tar xf $(ARCH_XTENSA_OVERLAY_FILE) -C $(@D) --strip-components=1 gcc
# endif
################################################################################
-ARCH_XTENSA_CORE_NAME = $(call qstrip,$(BR2_XTENSA_CORE_NAME))
-ARCH_XTENSA_OVERLAY_TAR = $(call qstrip,$(BR2_XTENSA_OVERLAY_DIR))/xtensa_$(ARCH_XTENSA_CORE_NAME).tar
+ARCH_XTENSA_OVERLAY_FILE = $(call qstrip,$(BR2_XTENSA_OVERLAY_FILE))
################################################################################
# arch-xtensa-overlay-extract -- extract an extensa overlay
@@ -24,5 +21,5 @@ ARCH_XTENSA_OVERLAY_TAR = $(call qstrip,$(BR2_XTENSA_OVERLAY_DIR))/xtensa_$(ARCH
# $(call arch-xtensa-overlay-extract,/path/to/overlay.tar,$(@D),gcc)
################################################################################
define arch-xtensa-overlay-extract
- tar xf $(ARCH_XTENSA_OVERLAY_TAR) -C $(1) --strip-components=1 $(2)
+ tar xf $(ARCH_XTENSA_OVERLAY_FILE) -C $(1) --strip-components=1 $(2)
endef
OpenPOWER on IntegriCloud