diff options
author | Arnout Vandecappelle <arnout@mind.be> | 2015-03-21 20:49:46 +0100 |
---|---|---|
committer | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2015-04-04 15:13:52 +0200 |
commit | f42a580a890895793310f3a2b806eed1af32379c (patch) | |
tree | 5f65da867ee64dd41cd42ad0bbb83671472caba1 /Makefile | |
parent | df79e35aa80327f95d6c57d1ef54b0d6604a84c6 (diff) | |
download | buildroot-f42a580a890895793310f3a2b806eed1af32379c.tar.gz buildroot-f42a580a890895793310f3a2b806eed1af32379c.zip |
Makefile: split off 'list-defconfigs' from 'help'
As discussed in the FOSDEM2015 BR developer meeting, the output of
'make help' is too long for comfortable reading. To shorten it, split
off the list of defconfigs in a new target, 'list-defconfigs'.
Declare the new target as phony.
Add 'list-defconfigs' to the documentation.
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 10 |
1 files changed, 6 insertions, 4 deletions
@@ -435,7 +435,7 @@ world: target-post-image .PHONY: all world toolchain dirs clean distclean source outputmakefile \ legal-info legal-info-prepare legal-info-clean printvars help \ - target-finalize target-post-image \ + list-defconfigs target-finalize target-post-image \ $(TARGETS) $(TARGETS_ROOTFS) \ $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) $(TARGETS_LEGAL_INFO) \ $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \ @@ -907,6 +907,11 @@ endif @echo ' make V=0|1 - 0 => quiet build (default), 1 => verbose build' @echo ' make O=dir - Locate all output files in "dir", including .config' @echo + @echo 'For further details, see README, generate the Buildroot manual, or consult' + @echo 'it on-line at http://buildroot.org/docs.html' + @echo + +list-defconfigs: @echo 'Built-in configs:' @$(foreach b, $(sort $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig))), \ printf " %-35s - Build for %s\\n" $(b) $(b:_defconfig=);) @@ -917,9 +922,6 @@ ifneq ($(wildcard $(BR2_EXTERNAL)/configs/*_defconfig),) printf " %-35s - Build for %s\\n" $(b) $(b:_defconfig=);) endif @echo - @echo 'For further details, see README, generate the Buildroot manual, or consult' - @echo 'it on-line at http://buildroot.org/docs.html' - @echo release: OUT = buildroot-$(BR2_VERSION) |