summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFabio Porcedda <fabio.porcedda@gmail.com>2014-03-06 10:42:27 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-06 22:50:48 +0100
commitcf53e15d09056cc9b72fc0d92b2a22e0e26ba989 (patch)
tree707e154a32f8d6a7e199ef7df0913644e7629289 /Makefile
parentb08cddec48d27105b8413ed2c89393658d01f642 (diff)
downloadbuildroot-cf53e15d09056cc9b72fc0d92b2a22e0e26ba989.tar.gz
buildroot-cf53e15d09056cc9b72fc0d92b2a22e0e26ba989.zip
Makefile: remove BASE_TARGETS variable
Because now the toolchain dependency is automatically added by the package infrastructure the BASE_TARGETS variable is useless so just remove it. Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index ae868dae27..2b1391740a 100644
--- a/Makefile
+++ b/Makefile
@@ -301,9 +301,7 @@ GNU_HOST_NAME:=$(shell support/gnuconfig/config.guess)
#
################################################################################
-BASE_TARGETS = toolchain
-
-TARGETS:=
+TARGETS:= toolchain
# silent mode requested?
QUIET:=$(if $(findstring s,$(MAKEFLAGS)),-q)
@@ -412,7 +410,7 @@ endif
include fs/common.mk
-TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS) $(BASE_TARGETS))
+TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
# host-* dependencies have to be handled specially, as those aren't
@@ -434,7 +432,7 @@ HOST_DEPS = $(sort $(foreach dep,\
HOST_SOURCE += $(addsuffix -source,$(sort $(TARGETS_HOST_DEPS) $(HOST_DEPS)))
TARGETS_LEGAL_INFO:=$(patsubst %,%-legal-info,\
- $(TARGETS) $(BASE_TARGETS) $(TARGETS_HOST_DEPS) $(HOST_DEPS))))
+ $(TARGETS) $(TARGETS_HOST_DEPS) $(HOST_DEPS))))
dirs: $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(HOST_DIR) $(BINARIES_DIR) $(STAMP_DIR)
@@ -453,7 +451,7 @@ world: target-post-image
.PHONY: all world toolchain dirs clean distclean source outputmakefile \
legal-info legal-info-prepare legal-info-clean printvars \
target-finalize target-post-image \
- $(BASE_TARGETS) $(TARGETS) $(TARGETS_ROOTFS) \
+ $(TARGETS) $(TARGETS_ROOTFS) \
$(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) $(TARGETS_LEGAL_INFO) \
$(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(HOST_DIR) $(BINARIES_DIR) $(STAMP_DIR)
OpenPOWER on IntegriCloud