summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-06-03 20:46:58 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-08 17:23:10 +0200
commitcef18e4085fdfa2b47a79bdc59126a827a24ae7e (patch)
tree1596b2e72f67e25771c13253e9b8046675d85936 /Makefile
parent07c642b735d03b83c31824afe0aa2bd6d31699b9 (diff)
downloadbuildroot-cef18e4085fdfa2b47a79bdc59126a827a24ae7e.tar.gz
buildroot-cef18e4085fdfa2b47a79bdc59126a827a24ae7e.zip
perl: removes useless files in target tree
$(TARGET_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE contains include files. *.bs & .packlist files come with perl or perl/cpan packages. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 08696f757c..55010687bf 100644
--- a/Makefile
+++ b/Makefile
@@ -554,6 +554,9 @@ ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY)$(BR2_PACKAGE_PYTHON3_PYC_ONLY),y)
find $(TARGET_DIR)/usr/lib/ -name '*.py' -print0 | xargs -0 rm -f
endif
rm -rf $(TARGET_DIR)/usr/lib/luarocks
+ rm -rf $(TARGET_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE
+ find $(TARGET_DIR)/usr/lib/perl5/ -name '*.bs' -print0 | xargs -0 rm -f
+ find $(TARGET_DIR)/usr/lib/perl5/ -name '.packlist' -print0 | xargs -0 rm -f
$(STRIP_FIND_CMD) | xargs $(STRIPCMD) 2>/dev/null || true
if test -d $(TARGET_DIR)/lib/modules; then \
find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
OpenPOWER on IntegriCloud