summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2014-06-19 00:10:24 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-29 10:52:19 +0200
commit790df63d353b4987a5f2aee5c67ee73378757b06 (patch)
tree6f1d2818d657dfd9c6b1977c37bf821b09582743 /Makefile
parent0f2faf78a5e0ea0bc24aa6589406082e63a52fb1 (diff)
downloadbuildroot-790df63d353b4987a5f2aee5c67ee73378757b06.tar.gz
buildroot-790df63d353b4987a5f2aee5c67ee73378757b06.zip
graph-depends: fix when $(O) is a relative path
The graph-depends commands cd into the CONFIG_DIR and run the script from there. However, this means that when $(O) is a relative path, it will no longer be correct. Therefore, use $(BASE_DIR) instead of $(O). Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4fe370abf3..9c54992c8f 100644
--- a/Makefile
+++ b/Makefile
@@ -681,8 +681,8 @@ graph-depends: graph-depends-requirements
@$(INSTALL) -d $(O)/graphs
@cd "$(CONFIG_DIR)"; \
$(TOPDIR)/support/scripts/graph-depends $(BR2_GRAPH_DEPS_OPTS) \
- |tee $(O)/graphs/$(@).dot \
- |dot $(BR2_GRAPH_DOT_OPTS) -T$(BR_GRAPH_OUT) -o $(O)/graphs/$(@).$(BR_GRAPH_OUT)
+ |tee $(BASE_DIR)/graphs/$(@).dot \
+ |dot $(BR2_GRAPH_DOT_OPTS) -T$(BR_GRAPH_OUT) -o $(BASE_DIR)/graphs/$(@).$(BR_GRAPH_OUT)
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
OpenPOWER on IntegriCloud