summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorKurt Van Dijck <dev.kurt@vandijck-laurijssen.be>2016-06-19 06:12:06 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-06-20 22:48:42 +0200
commit3f4c72c60793ca6ada24ae85c3211b2ab178eb3b (patch)
tree6b4fa9d22b180d9d27a108af8019150c63f2c7be /Makefile
parent052b46c6dcd689e8dc2e7dbe6e334a62c53e1bd1 (diff)
downloadbuildroot-3f4c72c60793ca6ada24ae85c3211b2ab178eb3b.tar.gz
buildroot-3f4c72c60793ca6ada24ae85c3211b2ab178eb3b.zip
build: fix umask test
Some shells' builtin umask does not print 2 leading 0's for the umask. Switching to bash is done anyway. This patch switches to bash before the umask test. Signed-off-by: Kurt Van Dijck <dev.kurt@vandijck-laurijssen.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 3f5c3d3b2f..78b44c5e4b 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,11 @@
# You shouldn't need to mess with anything beyond this point...
#--------------------------------------------------------------
+# we want bash as shell
+SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
+ else if [ -x /bin/bash ]; then echo /bin/bash; \
+ else echo sh; fi; fi)
+
# Trick for always running with a fixed umask
UMASK = 0022
ifneq ($(shell umask),$(UMASK))
@@ -227,11 +232,6 @@ else
Q = @
endif
-# we want bash as shell
-SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
- else if [ -x /bin/bash ]; then echo /bin/bash; \
- else echo sh; fi; fi)
-
# kconfig uses CONFIG_SHELL
CONFIG_SHELL := $(SHELL)
OpenPOWER on IntegriCloud