summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-04-13 22:42:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-14 20:56:17 +0200
commit22d05901c37820fe9fcfa606ab09e2c7325b2d31 (patch)
treee35a7d9727d30ba29cab8fd5ef9c2bd8fd7e983f /Makefile
parentd48eb62608a082be8b7261ab6d8afe490dc88b11 (diff)
downloadbuildroot-22d05901c37820fe9fcfa606ab09e2c7325b2d31.tar.gz
buildroot-22d05901c37820fe9fcfa606ab09e2c7325b2d31.zip
Makefile: rename non-user-facing variable
Variables should be prefixed with BR_ when they are not user-facing. As a side effect, the new variable is prettier than the previous one. :-) Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 41c51c6b2a..b0eec7f9a7 100644
--- a/Makefile
+++ b/Makefile
@@ -149,7 +149,7 @@ endif
# Need that early, before we scan packages
# Avoids doing the $(or...) everytime
-_BR2_GRAPH_OUT := $(or $(BR2_GRAPH_OUT),pdf)
+BR_GRAPH_OUT := $(or $(BR2_GRAPH_OUT),pdf)
BUILD_DIR:=$(BASE_DIR)/build
BINARIES_DIR:=$(BASE_DIR)/images
@@ -662,18 +662,18 @@ graph-build: $(O)/build/build-time.log
@install -d $(O)/graphs
$(foreach o,name build duration,./support/scripts/graph-build-time \
--type=histogram --order=$(o) --input=$(<) \
- --output=$(O)/graphs/build.hist-$(o).$(_BR2_GRAPH_OUT) \
+ --output=$(O)/graphs/build.hist-$(o).$(BR_GRAPH_OUT) \
$(if $(BR2_GRAPH_ALT),--alternate-colors)$(sep))
$(foreach t,packages steps,./support/scripts/graph-build-time \
--type=pie-$(t) --input=$(<) \
- --output=$(O)/graphs/build.pie-$(t).$(_BR2_GRAPH_OUT) \
+ --output=$(O)/graphs/build.pie-$(t).$(BR_GRAPH_OUT) \
$(if $(BR2_GRAPH_ALT),--alternate-colors)$(sep))
graph-depends:
@$(INSTALL) -d $(O)/graphs
@cd "$(CONFIG_DIR)"; \
$(TOPDIR)/support/scripts/graph-depends \
- |dot -T$(_BR2_GRAPH_OUT) -o $(O)/graphs/$(@).$(_BR2_GRAPH_OUT)
+ |dot -T$(BR_GRAPH_OUT) -o $(O)/graphs/$(@).$(BR_GRAPH_OUT)
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
OpenPOWER on IntegriCloud