summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoé Rubinstein <noe.rubinstein@gmail.com>2015-11-04 19:46:07 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-04 21:48:42 +0100
commitdb89b0b983735cacc2e417f2e40cad2b265b4543 (patch)
tree742c8ef18b5b40d34b0949f2df8716afb62c2cd4
parent407d77e9c1448a9eec9669346bac33218c3b29be (diff)
downloadbuildroot-db89b0b983735cacc2e417f2e40cad2b265b4543.tar.gz
buildroot-db89b0b983735cacc2e417f2e40cad2b265b4543.zip
package/python-web2py: fix permissions
The PYTHON_WEB2PY_PERMISSIONS table was using the user and group names instead of the uid and gid, causing makedevs to retrieve the uid and gid from the host system. Signed-off-by: Noé Rubinstein <nrubinstein@aldebaran.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/python-web2py/python-web2py.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/python-web2py/python-web2py.mk b/package/python-web2py/python-web2py.mk
index 313114ad69..db9ed8dfd8 100644
--- a/package/python-web2py/python-web2py.mk
+++ b/package/python-web2py/python-web2py.mk
@@ -32,8 +32,16 @@ define PYTHON_WEB2PY_INSTALL_INIT_SYSTEMD
$(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/web2py.service
endef
+# www-data user and group are used for web2py. Because these user and group
+# are already set by buildroot, it is not necessary to redefine them.
+# See system/skeleton/etc/passwd
+# username: www-data uid: 33
+# groupname: www-data gid: 33
+#
+# So, we just need to create the directories used by web2py with the right
+# ownership.
define PYTHON_WEB2PY_PERMISSIONS
- /var/www/web2py r 750 www-data www-data - - - - -
+ /var/www/web2py r 750 33 33 - - - - -
endef
$(eval $(generic-package))
OpenPOWER on IntegriCloud