summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-12-25 17:14:44 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-12-25 17:14:44 +0100
commit87815fc695bcb4ef5a48c09ab1ffcd0c134da43a (patch)
tree12f050db80793f9441e85a44de77962ce0266325
parent43e9128600c209b669cb0eca93717d5bc4fa08bd (diff)
downloadbuildroot-87815fc695bcb4ef5a48c09ab1ffcd0c134da43a.tar.gz
buildroot-87815fc695bcb4ef5a48c09ab1ffcd0c134da43a.zip
gnutls: fix libopts detection causing build failures
Following the recent bump of gnutls to version 3.2.8, the build started to fail on some machines where libopts is installed on the system: gnutls configure script was incorrectly assuming that libopts was available. Since we don't have a package in Buildroot, this commit tells gnutls to use its builtin libopts version. Fixes (tested on gcc20): http://autobuild.buildroot.org/results/18f/18f61b3be6aed73f83b449b5082492a4a6ba8ffb/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/gnutls/gnutls.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 7cbfcb1b76..9ad673e0ca 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -15,8 +15,12 @@ GNUTLS_DEPENDENCIES = host-pkgconf nettle pcre \
$(if $(BR2_PACKAGE_LIBIDN),libidn) \
$(if $(BR2_PACKAGE_LIBTASN1),libtasn1) \
$(if $(BR2_PACKAGE_ZLIB),zlib)
-GNUTLS_CONF_OPT = --with-libnettle-prefix=$(STAGING_DIR)/usr --disable-rpath \
- --disable-doc --disable-guile
+GNUTLS_CONF_OPT = \
+ --with-libnettle-prefix=$(STAGING_DIR)/usr \
+ --disable-rpath \
+ --disable-doc \
+ --disable-guile \
+ --enable-local-libopts
GNUTLS_CONF_ENV = gl_cv_socket_ipv6=$(if $(BR2_INET_IPV6),yes,no) \
ac_cv_header_wchar_h=$(if $(BR2_USE_WCHAR),yes,no) \
gt_cv_c_wchar_t=$(if $(BR2_USE_WCHAR),yes,no) \
OpenPOWER on IntegriCloud