summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2014-09-14 13:07:35 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-09-21 20:11:02 +0200
commit64982ce4fa7c5131e90ea18ef761940435d8873a (patch)
tree5b0264d381dd859e4238d0ce1f34831540f31978
parent7cb90f1516b5b0b70fef2ce6eb5ff67d966ac2d7 (diff)
downloadbuildroot-64982ce4fa7c5131e90ea18ef761940435d8873a.tar.gz
buildroot-64982ce4fa7c5131e90ea18ef761940435d8873a.zip
gendoc infra: cosmetic fixes
- wrap lines to 80 characters - fix space/tab mixup Signed-off-by: Samuel Martin <s.martin49@gmail.com> Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> [yann.morin.1998@free.fr: tested all but PDF] Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--docs/manual/manual.mk13
1 files changed, 8 insertions, 5 deletions
diff --git a/docs/manual/manual.mk b/docs/manual/manual.mk
index 8d401a21d7..136f725af7 100644
--- a/docs/manual/manual.mk
+++ b/docs/manual/manual.mk
@@ -70,8 +70,8 @@ $$(O)/docs/$(1)/$(1).$(4): docs/$(1)/$(1).txt \
$$(Q)mkdir -p $$(@D)/.build
$$(Q)rsync -au docs/$(1)/*.txt $$(@D)/.build
$$(Q)a2x $(6) -f $(2) -d book -L -r $$(TOPDIR)/docs/images \
- -D $$(@D) $$(@D)/.build/$(1).txt \
- --asciidoc-opts="$$(MANUAL_$(2)_ASCIIDOC_OPTS)"
+ --asciidoc-opts="$$(MANUAL_$(2)_ASCIIDOC_OPTS)" \
+ -D $$(@D) $$(@D)/.build/$(1).txt
-$$(Q)rm -rf $$(@D)/.build
endef
@@ -84,9 +84,12 @@ endef
# The variable <DOCUMENT_NAME>_SOURCES defines the dependencies.
################################################################################
define GENDOC
-$(call GENDOC_INNER,$(pkgname),xhtml,html,html,HTML,--xsltproc-opts "--stringparam toc.section.depth 1")
-$(call GENDOC_INNER,$(pkgname),chunked,split-html,chunked,split HTML,--xsltproc-opts "--stringparam toc.section.depth 1")
-$(call GENDOC_INNER,$(pkgname),pdf,pdf,pdf,PDF,--dblatex-opts "-P latex.output.revhistory=0")
+$(call GENDOC_INNER,$(pkgname),xhtml,html,html,HTML,\
+ --xsltproc-opts "--stringparam toc.section.depth 1")
+$(call GENDOC_INNER,$(pkgname),chunked,split-html,chunked,split HTML,\
+ --xsltproc-opts "--stringparam toc.section.depth 1")
+$(call GENDOC_INNER,$(pkgname),pdf,pdf,pdf,PDF,\
+ --dblatex-opts "-P latex.output.revhistory=0")
$(call GENDOC_INNER,$(pkgname),text,text,text,text)
$(call GENDOC_INNER,$(pkgname),epub,epub,epub,ePUB)
clean: $(pkgname)-clean
OpenPOWER on IntegriCloud