summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-10-13 08:19:55 -0300
committerPeter Korsgaard <peter@korsgaard.com>2016-10-15 11:15:26 +0200
commit5130e9f874ea07db417a02b6d78d118a8cd6a068 (patch)
tree40d77fd7c54e40175ecd0175c836dda46a93d5de
parent9f4483f7cefebc6a489c1eeab7f6468be5561f27 (diff)
downloadbuildroot-5130e9f874ea07db417a02b6d78d118a8cd6a068.tar.gz
buildroot-5130e9f874ea07db417a02b6d78d118a8cd6a068.zip
libgpgme: improve language bindings
The C++ bindings require C++11 support with minimum gcc version 4.8, so handle it accordingly. The new python bindings require some work, but since they were previously unavailable just disable them for now until someone is interested in building/using them. Fixes: http://autobuild.buildroot.net/results/685/6853c21aa084952bc232f0ec3e96dcb972d8fbfe/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/libgpgme/libgpgme.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/libgpgme/libgpgme.mk b/package/libgpgme/libgpgme.mk
index 7e86daf95c..c581a3c496 100644
--- a/package/libgpgme/libgpgme.mk
+++ b/package/libgpgme/libgpgme.mk
@@ -11,6 +11,7 @@ LIBGPGME_LICENSE = LGPLv2.1+
LIBGPGME_LICENSE_FILES = COPYING.LESSER
LIBGPGME_INSTALL_STAGING = YES
LIBGPGME_DEPENDENCIES = libassuan libgpg-error
+LIBGPGME_LANGUAGE_BINDINGS = cl
# libgpgme, needs to know the gpg binary path on the target.
LIBGPGME_CONF_OPTS = --with-gpg=/usr/bin/gpg \
@@ -19,7 +20,13 @@ LIBGPGME_CONF_OPTS = --with-gpg=/usr/bin/gpg \
--disable-gpgsm-test \
--disable-gpgconf-test \
--disable-g13-test \
- --disable-gpg-test
+ --disable-gpg-test \
+ --enable-languages=$(LIBGPGME_LANGUAGE_BINDINGS)
+
+# C++ bindings require a C++11 capable gcc
+ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_TOOLCHAIN_GCC_AT_LEAST_4_8),yy)
+LIBGPGME_LANGUAGE_BINDINGS := $(LIBGPGME_LANGUAGE_BINDINGS),cpp
+endif
# Handle argp-standalone or it errors out during build
ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
OpenPOWER on IntegriCloud