summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEzequiel Garcia <ezequiel.garcia@free-electrons.com>2013-10-30 12:22:25 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-12-25 16:44:13 +0100
commit43e9128600c209b669cb0eca93717d5bc4fa08bd (patch)
treede6fff6b5d41394b242e05d00de1113c6a30e78f
parentb7cac3e86e7e568410a6fefcb9cdabeb068871cd (diff)
downloadbuildroot-43e9128600c209b669cb0eca93717d5bc4fa08bd.tar.gz
buildroot-43e9128600c209b669cb0eca93717d5bc4fa08bd.zip
fio: new package
[Thomas: add largefile and thread dependencies, bump to version 2.1.4, use upstream Git instead of Debian tarballs, adjust license information] Signed-off-by: Ezequiel Garcia <ezequiel.garcia@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Config.in1
-rw-r--r--package/fio/Config.in13
-rw-r--r--package/fio/fio.mk24
3 files changed, 38 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index fe31cd2b0a..76f8d4f82f 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -47,6 +47,7 @@ source "package/dmalloc/Config.in"
source "package/dropwatch/Config.in"
source "package/dstat/Config.in"
source "package/duma/Config.in"
+source "package/fio/Config.in"
source "package/gdb/Config.in"
source "package/iozone/Config.in"
source "package/kexec/Config.in"
diff --git a/package/fio/Config.in b/package/fio/Config.in
new file mode 100644
index 0000000000..deff12c9ff
--- /dev/null
+++ b/package/fio/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_FIO
+ bool "fio"
+ depends on BR2_USE_MMU # fork()
+ depends on BR2_LARGEFILE
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ fio is an I/O tool meant to be used both for benchmark
+ and stress/hardware verification.
+
+ http://git.kernel.dk/?p=fio.git;a=summary
+
+comment "fio needs a toolchain w/ largefile, threads"
+ depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/fio/fio.mk b/package/fio/fio.mk
new file mode 100644
index 0000000000..f9a690e7cf
--- /dev/null
+++ b/package/fio/fio.mk
@@ -0,0 +1,24 @@
+################################################################################
+#
+# fio
+#
+################################################################################
+
+FIO_VERSION = fio-2.1.4
+FIO_SITE = git://git.kernel.dk/fio.git
+FIO_LICENSE = GPLv2 + special obligations
+FIO_LICENSE_FILES = LICENSE
+
+define FIO_CONFIGURE_CMDS
+ (cd $(@D); ./configure --cc="$(TARGET_CC)" --extra-cflags="$(TARGET_CFLAGS)")
+endef
+
+define FIO_BUILD_CMDS
+ $(MAKE) -C $(@D)
+endef
+
+define FIO_INSTALL_TARGET_CMDS
+ $(INSTALL) -D $(@D)/fio $(TARGET_DIR)/usr/bin/fio
+endef
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud