summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-07-27 18:34:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-28 22:29:09 +0200
commit353e223d1471604f2c059d10a176b94a68e408ae (patch)
tree8ff4ce3c3e92233c373c40390e922d4c8e531f44
parent1756b3c5405df7afda438b50904d8b0690e9b2a3 (diff)
downloadbuildroot-353e223d1471604f2c059d10a176b94a68e408ae.tar.gz
buildroot-353e223d1471604f2c059d10a176b94a68e408ae.zip
perl: handle BR2_PREFER_STATIC_LIB
[Thomas: fix commit title, use one line for both CONF_OPT options.] Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--Makefile1
-rw-r--r--package/perl/perl.mk4
2 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index d4ef081f52..258495c76a 100644
--- a/Makefile
+++ b/Makefile
@@ -579,6 +579,7 @@ endif
rm -rf $(TARGET_DIR)/usr/lib/luarocks
rm -rf $(TARGET_DIR)/usr/lib/perl5/$(PERL_VERSION)/pod
rm -rf $(TARGET_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE
+ find $(TARGET_DIR)/usr/lib/perl5/ -name 'extralibs.ld' -print0 | xargs -0 rm -f
find $(TARGET_DIR)/usr/lib/perl5/ -name '*.bs' -print0 | xargs -0 rm -f
find $(TARGET_DIR)/usr/lib/perl5/ -name '.packlist' -print0 | xargs -0 rm -f
$(STRIP_FIND_CMD) | xargs $(STRIPCMD) 2>/dev/null || true
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index 8321570fad..e4aad7f6c5 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -69,6 +69,10 @@ ifeq ($(shell expr $(PERL_VERSION_MAJOR) % 2), 1)
PERL_CONF_OPT += -Dusedevel
endif
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ PERL_CONF_OPT += --all-static --no-dynaloader
+endif
+
ifneq ($(BR2_LARGEFILE),y)
PERL_CONF_OPT += -Uuselargefiles
endif
OpenPOWER on IntegriCloud