summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-06 11:42:29 +0200
committerPeter Korsgaard <peter@korsgaard.com>2017-07-06 11:54:51 +0200
commit27ce235cdb996dc691c28a95f6acc9c479ef1fb8 (patch)
tree938d9c602afb4ad189c19085e80898d10b1d498b
parent0efb7785eab110dc8860c271c361fdf67d3d1fb7 (diff)
downloadbuildroot-27ce235cdb996dc691c28a95f6acc9c479ef1fb8.tar.gz
buildroot-27ce235cdb996dc691c28a95f6acc9c479ef1fb8.zip
xvisor: fix bogus check on XVISOR_ARCH
The XVISOR_ARCH check added in commit 117fd5dfbc756c4f2b4aef97fc2b568528c66df7 ("xvisor: fix build on AArch64") broke Buildroot entirely on all architectures except ARM, AArch64 and x86-64, because the $(error ...) test was not enclosed inside a condition that made sure the xvisor package was enabled. This commit fixes that, and allows Buildroot to be usable again on all architectures. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/xvisor/xvisor.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/xvisor/xvisor.mk b/package/xvisor/xvisor.mk
index 8be4be9df1..addd7e6998 100644
--- a/package/xvisor/xvisor.mk
+++ b/package/xvisor/xvisor.mk
@@ -30,9 +30,13 @@ ifeq ($(BR2_x86_64),y)
XVISOR_ARCH = x86
else ifeq ($(BR2_arm)$(BR2_aarch64),y)
XVISOR_ARCH = arm
-else
+endif
+
+ifeq ($(BR2_PACKAGE_XVISOR)$(BR_BUILDING),yy)
+ifeq ($(XVISOR_ARCH),)
$(error "Architecture not supported by XVisor")
endif
+endif
XVISOR_MAKE_ENV = \
ARCH=$(XVISOR_ARCH) \
OpenPOWER on IntegriCloud