summaryrefslogtreecommitdiffstats
path: root/yocto-poky/meta-poky/recipes-core/tiny-init
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta-poky/recipes-core/tiny-init')
-rw-r--r--yocto-poky/meta-poky/recipes-core/tiny-init/files/init26
-rw-r--r--yocto-poky/meta-poky/recipes-core/tiny-init/files/rc.local.sample23
-rw-r--r--yocto-poky/meta-poky/recipes-core/tiny-init/tiny-init.bb30
3 files changed, 0 insertions, 79 deletions
diff --git a/yocto-poky/meta-poky/recipes-core/tiny-init/files/init b/yocto-poky/meta-poky/recipes-core/tiny-init/files/init
deleted file mode 100644
index 9140e9558..000000000
--- a/yocto-poky/meta-poky/recipes-core/tiny-init/files/init
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-
-# Mount the Linux kernel virtual filesystems
-mount none -t proc /proc
-mount none -t sysfs /sys
-
-# Ensure devtmpfs is mounted, it must be done manually with initramfs
-mount none -t devtmpfs /dev
-
-# Setup PTY infrastructure
-mkdir /dev/pts
-mount none -t devpts /dev/pts
-
-ifup lo
-
-# Allow for distro or local customizations
-if [ -f /etc/rc.local ] ; then
- . /etc/rc.local
-fi
-
-# Become session leader and try to find a real tty (e.g. ttyS0)
-while true; do
- setsid cttyhack sh
- echo "Console sh exited with $?, respawning..."
- sleep 1
-done
diff --git a/yocto-poky/meta-poky/recipes-core/tiny-init/files/rc.local.sample b/yocto-poky/meta-poky/recipes-core/tiny-init/files/rc.local.sample
deleted file mode 100644
index d9e198a20..000000000
--- a/yocto-poky/meta-poky/recipes-core/tiny-init/files/rc.local.sample
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-
-# Start services and customize the boot process here.
-echo "Running /etc/rc.local..."
-
-# Use init scripts included with packages such as dropbear
-#/etc/init.d/dropbear start
-
-# Spawn a getty manually
-#setsid /sbin/getty 115200 ttyS2
-
-# Print a banner
-#echo "You are running a poky-tiny image brought to you by the Yocto Project."
-
-# Setup a debugging environment
-#mkdir /debugfs
-#mount none -t debugfs /debugfs
-
-# Load modules (note: linux-yocto-tiny does not have module support by default)
-#modprobe yourdriver
-
-# DO NOT run any long running tasks or loops as these will delay
-# the /init script and the console shell.
diff --git a/yocto-poky/meta-poky/recipes-core/tiny-init/tiny-init.bb b/yocto-poky/meta-poky/recipes-core/tiny-init/tiny-init.bb
deleted file mode 100644
index 4d4e34dc8..000000000
--- a/yocto-poky/meta-poky/recipes-core/tiny-init/tiny-init.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Poky-tiny init"
-DESCRIPTION = "Basic init system for poky-tiny"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-PR = "r2"
-
-RDEPENDS_${PN} = "busybox"
-
-SRC_URI = "file://init \
- file://rc.local.sample \
- "
-
-S = "${WORKDIR}"
-
-do_configure() {
- :
-}
-
-do_compile() {
- :
-}
-
-do_install() {
- install -d ${D}${sysconfdir}
- install -m 0755 ${WORKDIR}/init ${D}
- install -m 0755 ${WORKDIR}/rc.local.sample ${D}${sysconfdir}
-}
-
-FILES_${PN} = "/init ${sysconfdir}/rc.local.sample"
OpenPOWER on IntegriCloud