path: root/lib/crc16.c
Commit message (Collapse)AuthorAgeFilesLines
* lib/crc16.c: Rename cyg_crc16() to crc16_ccitt() and add crc start valueStefan Roese2016-03-141-2/+2
| | | | | | | | | | | | | The original name of this function is unclear. This patch renames this CRC16 function to crc16_ccitt() matching its name with its implementation. To make the usage of this function more flexible, lets add the CRC start value as parameter to this function. This way it can be used by other functions requiring different start values than 0 as well. Signed-off-by: Stefan Roese <> Reviewed-by: Tom Rini <>
* lib/crc16.c: Coding-style cleanupStefan Roese2016-03-141-41/+40
| | | | | | | lib/crc16.c is changed to match the common U-Boot coding-style. Signed-off-by: Stefan Roese <> Reviewed-by: Tom Rini <>
* Add eCos-2.0 SPDX-License-Identifier to source filesWolfgang Denk2013-07-241-33/+1
| | | | Signed-off-by: Wolfgang Denk <>
* Rename lib_generic/ to lib/Peter Tyser2010-04-131-0/+107
Now that the other architecture-specific lib directories have been moved out of the top-level directory there's not much reason to have the '_generic' suffix on the common lib directory. Signed-off-by: Peter Tyser <>
OpenPOWER on IntegriCloud