summaryrefslogtreecommitdiffstats
path: root/board/esd/common/auto_update.c
Commit message (Collapse)AuthorAgeFilesLines
* ppc4xx: cleanup CPCI4052 boardMatthias Fuchs2015-01-131-478/+0
| | | | | | | - remove some obsolete code - switch to generic board Signed-off-by: Matthias Fuchs <matthias.fuchs@esd.eu>
* fat: Prepare API change for files greater than 2GBSuriyan Ramasami2014-11-231-3/+0
| | | | | | | | | Change the internal FAT functions to use loff_t for offsets. Signed-off-by: Suriyan Ramasami <suriyan.r@gmail.com> Acked-by: Simon Glass <sjg@chromium.org> [trini: Fix fs/fat/fat.c for min3 updates] Signed-off-by: Tom Rini <trini@ti.com>
* board/esd/common/auto_update.c: Use <flash.h>Tom Rini2014-11-231-3/+1
| | | | | | A number of prototypes here are now found in <flash.h>. use. Signed-off-by: Tom Rini <trini@ti.com>
* board/esd/common/auto_update.c: fix Uninitialized variableWolfgang Denk2014-11-101-2/+1
| | | | | | | | | | | | cppcheck reports: [board/esd/common/auto_update.c:458]: (error) Uninitialized variable: cnt The variable is not really used anywhere, so remove it. Signed-off-by: Wolfgang Denk <wd@denx.de> Cc: Matthias Fuchs <matthias.fuchs@esd-electronics.com> Acked-by: Matthias Fuchs <matthias.fuchs@esd.eu>
* Add GPL-2.0+ SPDX-License-Identifier to source filesWolfgang Denk2013-07-241-17/+1
| | | | | | Signed-off-by: Wolfgang Denk <wd@denx.de> [trini: Fixup common/cmd_io.c] Signed-off-by: Tom Rini <trini@ti.com>
* Stop using builtin_run_command()Simon Glass2012-03-061-1/+1
| | | | | | | | | | Boards can select either the 'built-in' parser or the hush parser. We should not call builtin_run_command() if we are using the hush parser. We use run_command() instead, since it knows how to call the correct parser. Signed-off-by: Simon Glass <sjg@chromium.org> Acked-by: Mike Frysinger <vapier@gentoo.org>
* Rename run_command() to builtin_run_command()Simon Glass2012-03-061-1/+1
| | | | | | | | | The current run_command() is only one of the parsing options - the other is hush. We should not call run_command() when the hush parser is being used. So we rename this function to better explain its purpose. Signed-off-by: Simon Glass <sjg@chromium.org> Acked-by: Mike Frysinger <vapier@gentoo.org>
* auto_update.c: Fix GCC 4.6 build warningsStefan Roese2011-11-161-7/+1
| | | | | | | | | | Fix: ../common/auto_update.c: In function 'au_check_header_valid': ../common/auto_update.c:94:16: warning: variable 'checksum' set but not used [-Wunused-but-set-variable] ../common/auto_update.c: In function 'do_auto_update': ../common/auto_update.c:400:30: warning: variable 'got_ctrlc' set but not used [-Wunused-but-set-variable] Signed-off-by: Stefan Roese <sr@denx.de>
* Make sure that argv[] argument pointers are not modified.Wolfgang Denk2010-07-041-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The hush shell dynamically allocates (and re-allocates) memory for the argument strings in the "char *argv[]" argument vector passed to commands. Any code that modifies these pointers will cause serious corruption of the malloc data structures and crash U-Boot, so make sure the compiler can check that no such modifications are being done by changing the code into "char * const argv[]". This modification is the result of debugging a strange crash caused after adding a new command, which used the following argument processing code which has been working perfectly fine in all Unix systems since version 6 - but not so in U-Boot: int main (int argc, char **argv) { while (--argc > 0 && **++argv == '-') { /* ====> */ while (*++*argv) { switch (**argv) { case 'd': debug++; break; ... default: usage (); } } } ... } The line marked "====>" will corrupt the malloc data structures and usually cause U-Boot to crash when the next command gets executed by the shell. With the modification, the compiler will prevent this with an error: increment of read-only location '*argv' N.B.: The code above can be trivially rewritten like this: while (--argc > 0 && **++argv == '-') { char *arg = *argv; while (*++arg) { switch (*arg) { ... Signed-off-by: Wolfgang Denk <wd@denx.de> Acked-by: Mike Frysinger <vapier@gentoo.org>
* Remove legacy NAND and disk on chip references from boards.Scott Wood2009-07-171-50/+0
| | | | Signed-off-by: Scott Wood <scottwood@freescale.com>
* General help message cleanupWolfgang Denk2009-06-121-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Many of the help messages were not really helpful; for example, many commands that take no arguments would not print a correct synopsis line, but "No additional help available." which is not exactly wrong, but not helpful either. Commit ``Make "usage" messages more helpful.'' changed this partially. But it also became clear that lots of "Usage" and "Help" messages (fields "usage" and "help" in struct cmd_tbl_s respective) were actually redundant. This patch cleans this up - for example: Before: => help dtt dtt - Digital Thermometer and Thermostat Usage: dtt - Read temperature from digital thermometer and thermostat. After: => help dtt dtt - Read temperature from Digital Thermometer and Thermostat Usage: dtt Signed-off-by: Wolfgang Denk <wd@denx.de>
* Fix e-mail address of Gary Jennejohn.Detlev Zundel2009-05-151-1/+1
| | | | Signed-off-by: Detlev Zundel <dzu@denx.de>
* Command usage cleanupPeter Tyser2009-01-281-1/+1
| | | | | | | | Remove command name from all command "usage" fields and update common/command.c to display "name - usage" instead of just "usage". Also remove newlines from command usage fields. Signed-off-by: Peter Tyser <ptyser@xes-inc.com>
* rename CFG_ macros to CONFIG_SYSJean-Christophe PLAGNIOL-VILLARD2008-10-181-3/+3
| | | | Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
* drivers/mtd/nand: Move conditional compilation to MakefileJean-Christophe PLAGNIOL-VILLARD2008-08-131-6/+6
| | | | | | rename CFG_NAND_LEGACY to CONFIG_NAND_LEGACY Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
* ppc4xx: update esd's common auto_update code for 405 boardsMatthias Fuchs2008-04-221-112/+96
| | | | | | | | - Coding style cleanup (long lines) - improve handling of protected flash regions - remove dead code Signed-off-by: Matthias Fuchs <matthias.fuchs@esd-electronics.com>
* [new uImage] Update naming convention for bootm/uImage related codeMarian Balakowicz2008-02-291-3/+3
| | | | | | | | | | | | | | | This patch introduces the following prefix convention for the image format handling and bootm related code: genimg_ - dual format shared code image_ - legacy uImage format specific code fit_ - new uImage format specific code boot_ - booting process related code Related routines are renamed and a few pieces of code are moved around and re-grouped. Signed-off-by: Marian Balakowicz <m8@semihalf.com>
* [new uImage] Add dual format uImage support frameworkMarian Balakowicz2008-02-251-0/+19
| | | | | | | | | | | | | | This patch adds framework for dual format images. Format detection is added and the bootm controll flow is updated to include cases for new FIT format uImages. When the legacy (image_header based) format is detected appropriate legacy specific handling is invoked. For the new (FIT based) format uImages dual boot framework has a minial support, that will only print out a corresponding debug messages. Implementation of the FIT specific handling will be added in following patches. Signed-off-by: Marian Balakowicz <m8@semihalf.com>
* [new uImage] Define a API for image handling operationsMarian Balakowicz2008-02-071-40/+33
| | | | | | | | | - Add inline helper macros for basic header processing - Move common non inline code common/image.c - Replace direct header access with the API routines - Rename IH_CPU_* to IH_ARCH_* Signed-off-by: Marian Balakowicz <m8@semihalf.com>
* Merge with git://www.denx.de/git/u-boot.gitStefan Roese2007-08-161-0/+4
|\
| * Merge with git://www.denx.de/git/u-boot.gitStefan Roese2007-08-151-9/+9
| |\
| * | Migrate esd 405EP boards to new NAND subsystemMatthias Fuchs2007-07-091-0/+4
| | | | | | | | | | | | | | | | | | | | | This patch prepares the migration from the legacy NAND driver to U-Boot's new NAND subsystem for esd boards. Signed-off-by: Matthias Fuchs <matthias.fuchs@esd-electronics.com>
* | | ppc4xx: Remove #warning in esd auto_update.cStefan Roese2007-08-161-4/+0
| |/ |/| | | | | Signed-off-by: Stefan Roese <sr@denx.de>
* | board/[A-Za-i]*: Remove lingering references to CFG_CMD_* symbols.Jon Loeliger2007-07-101-1/+1
| | | | | | | | | | | | | | | | Fixed some broken instances of "#ifdef CMD_CFG_IDE" too. Those always evaluated TRUE, and thus were always compiled even when IDE really wasn't defined/wanted. Signed-off-by: Jon Loeliger <jdl@freescale.com>
* | board/[d-e]*: Remove obsolete references to CONFIG_COMMANDSJon Loeliger2007-07-091-8/+8
| | | | | | | | Signed-off-by: Jon Loeliger <jdl@freescale.com>
* | board/[Ma-i]*: Augment CONFIG_COMMANDS tests with defined(CONFIG_CMD_*).Jon Loeliger2007-07-041-7/+7
|/ | | | | | | | | | | | | | This is a compatibility step that allows both the older form and the new form to co-exist for a while until the older can be removed entirely. All transformations are of the form: Before: #if (CONFIG_COMMANDS & CFG_CMD_AUTOSCRIPT) After: #if (CONFIG_COMMANDS & CFG_CMD_AUTOSCRIPT) || defined(CONFIG_CMD_AUTOSCRIPT) Signed-off-by: Jon Loeliger <jdl@freescale.com>
* [PATCH 1_4] Merge common get_dev() routines for block devicesGrant Likely2007-02-201-2/+1
| | | | | | | Each of the filesystem drivers duplicate the get_dev routine. This change merges them into a single function in part.c Signed-off-by: Grant Likely <grant.likely@secretlab.ca>
* Fix JFFS2 support for legacy NAND driver.Marian Balakowicz2006-04-081-8/+8
| | | | Some more NAND cleanup and small fixes.
* Minor code cleanupWolfgang Denk2006-03-061-3/+0
|
* Re-factoring the legacy NAND code (legacy NAND now only in board-specificBartlomiej Sieka2006-03-051-10/+18
| | | | | | | code and in SoC code). Boards using the old way have CFG_NAND_LEGACY and BOARDLIBS = drivers/nand_legacy/libnand_legacy.a added. Build breakage for NETTA.ERR and NETTA_ISDN - will go away when the new NAND support is implemented for these boards.
* Fix various compiler warnings on ppc4xx builds (ELDK 4.0)Stefan Roese2006-01-181-1/+1
| | | | Patch by Stefan Roese, 18 Jan 2006
* Fix conflicting types (flash_write()) in esd auto_update.cStefan Roese2005-10-201-1/+1
| | | | Patch by Stefan Roese, 20 Oct 2005
* Cleanup for GCC-4.xWolfgang Denk2005-10-131-7/+7
|
* Update for esd auto_update and hh405 boardstroese2005-03-161-0/+19
|
* esd common updatestroese2004-12-161-0/+537
OpenPOWER on IntegriCloud