summaryrefslogtreecommitdiffstats
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 28c988e034c..65c5b2ab968 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -137,23 +137,6 @@ if (NOT LLDB_DISABLE_PYTHON)
endif()
endif()
find_package(PythonLibs REQUIRED)
- # PYTHON_LIBRARIES is now a list in the form (debug DebugPath optimized OptimizedPath)
- # So we need to parse it to get the path to the respective installations.
- list(FIND PYTHON_LIBRARIES optimized PYTHON_OPTIMIZED_INDEX)
- list(FIND PYTHON_LIBRARIES debug PYTHON_DEBUG_INDEX)
- if (NOT ${PYTHON_OPTIMIZED_INDEX} EQUAL -1)
- MATH(EXPR PYTHON_OPTIMIZED_INDEX "${PYTHON_OPTIMIZED_INDEX}+1")
- list(GET PYTHON_LIBRARIES ${PYTHON_OPTIMIZED_INDEX} PYTHON_RELEASE_LIBRARY)
- endif()
- if (NOT ${PYTHON_DEBUG_INDEX} EQUAL -1)
- MATH(EXPR PYTHON_DEBUG_INDEX "${PYTHON_DEBUG_INDEX}+1")
- list(GET PYTHON_LIBRARIES ${PYTHON_DEBUG_INDEX} PYTHON_DEBUG_LIBRARY)
- endif()
- if (CMAKE_BUILD_TYPE STREQUAL "Debug")
- set(PYTHON_LIBRARY ${PYTHON_DEBUG_LIBRARY})
- else()
- set(PYTHON_LIBRARY ${PYTHON_RELEASE_LIBRARY})
- endif()
include_directories(${PYTHON_INCLUDE_DIRS})
endif()
OpenPOWER on IntegriCloud