summaryrefslogtreecommitdiffstats
path: root/compiler-rt/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler-rt/test/CMakeLists.txt')
-rw-r--r--compiler-rt/test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/compiler-rt/test/CMakeLists.txt b/compiler-rt/test/CMakeLists.txt
index e691eab7d4a..0acf87bc858 100644
--- a/compiler-rt/test/CMakeLists.txt
+++ b/compiler-rt/test/CMakeLists.txt
@@ -10,7 +10,7 @@ configure_lit_site_cfg(
set(SANITIZER_COMMON_LIT_TEST_DEPS)
-if (COMPILER_RT_HAS_PROFILE)
+if(COMPILER_RT_BUILD_PROFILE AND COMPILER_RT_HAS_PROFILE)
list(APPEND SANITIZER_COMMON_LIT_TEST_DEPS profile)
endif()
@@ -72,7 +72,7 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
endif()
endforeach()
endif()
- if (COMPILER_RT_HAS_PROFILE)
+ if(COMPILER_RT_BUILD_PROFILE AND COMPILER_RT_HAS_PROFILE)
compiler_rt_test_runtime(profile)
endif()
if(COMPILER_RT_BUILD_XRAY)
OpenPOWER on IntegriCloud