summaryrefslogtreecommitdiffstats
path: root/lldb/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTodd Fiala <todd.fiala@gmail.com>2015-09-03 18:58:44 +0000
committerTodd Fiala <todd.fiala@gmail.com>2015-09-03 18:58:44 +0000
commitfed95660f39e0537afde67c25fd4a6ba969465bf (patch)
tree7c33fb4b1617ab747f15e7410b98d76be68a29ff /lldb/test/CMakeLists.txt
parent222edc66d6342034eb456b40b4370dddeed5324f (diff)
downloadbcm5719-llvm-fed95660f39e0537afde67c25fd4a6ba969465bf.tar.gz
bcm5719-llvm-fed95660f39e0537afde67c25fd4a6ba969465bf.zip
Roll dosep.py parallel test runner into dotest.py command line
See the following for details: http://reviews.llvm.org/D12587 llvm-svn: 246794
Diffstat (limited to 'lldb/test/CMakeLists.txt')
-rw-r--r--lldb/test/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/lldb/test/CMakeLists.txt b/lldb/test/CMakeLists.txt
index 49c2f4892e8..1397c664d75 100644
--- a/lldb/test/CMakeLists.txt
+++ b/lldb/test/CMakeLists.txt
@@ -62,16 +62,16 @@ endif()
add_python_test_target(check-lldb-single
${LLDB_SOURCE_DIR}/test/dotest.py
- "${LLDB_TEST_COMMON_ARGS};${LLDB_TEST_USER_ARGS}"
+ "--no-multiprocess;${LLDB_TEST_COMMON_ARGS};${LLDB_TEST_USER_ARGS}"
"Testing LLDB with args: ${LLDB_TEST_COMMON_ARGS};${LLDB_TEST_USER_ARGS}"
)
-set(LLDB_DOSEP_ARGS -o;\"-q;${LLDB_TEST_COMMON_ARGS};${LLDB_TEST_USER_ARGS}\")
+set(LLDB_DOTEST_ARGS -q;${LLDB_TEST_COMMON_ARGS};${LLDB_TEST_USER_ARGS})
# If tests crash cause LLDB to crash, or things are otherwise unstable, or if machine-parsable
# output is desired (i.e. in continuous integration contexts) check-lldb-single is a better target.
add_python_test_target(check-lldb
- ${LLDB_SOURCE_DIR}/test/dosep.py
- "${LLDB_DOSEP_ARGS}"
- "Testing LLDB (with a separate subprocess per test)"
+ ${LLDB_SOURCE_DIR}/test/dotest.py
+ "${LLDB_DOTEST_ARGS}"
+ "Testing LLDB (parallel execution, with a separate subprocess per test)"
)
OpenPOWER on IntegriCloud