summaryrefslogtreecommitdiffstats
path: root/lldb/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPavel Labath <labath@google.com>2018-01-29 10:02:40 +0000
committerPavel Labath <labath@google.com>2018-01-29 10:02:40 +0000
commit1902ffd9a4914d4cd03e200ca9050bf3b1564c19 (patch)
tree8c37c107afd7c2d25c3442c5f5133334aac868ac /lldb/test/CMakeLists.txt
parentc560a18c7f1befbdae2dd71b52517a7af597822b (diff)
downloadbcm5719-llvm-1902ffd9a4914d4cd03e200ca9050bf3b1564c19.tar.gz
bcm5719-llvm-1902ffd9a4914d4cd03e200ca9050bf3b1564c19.zip
[lldb] Generic base for testing gdb-remote behavior
Summary: Adds new utilities that make it easier to write test cases for lldb acting as a client over a gdb-remote connection. - A GDBRemoteTestBase class that starts a mock GDB server and provides an easy way to check client packets - A MockGDBServer that, via MockGDBServerResponder, can be made to issue server responses that test client behavior. - Utility functions for handling common data encoding/decoding - Utility functions for creating dummy targets from YAML files ---- Split from the review at https://reviews.llvm.org/D42145, which was a new feature that necessitated the new testing capabilities. Reviewers: clayborg, labath Reviewed By: clayborg, labath Subscribers: hintonda, davide, jingham, krytarowski, mgorny, lldb-commits Differential Revision: https://reviews.llvm.org/D42195 Patch by Owen Shaw <llvm@owenpshaw.net> llvm-svn: 323636
Diffstat (limited to 'lldb/test/CMakeLists.txt')
-rw-r--r--lldb/test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/lldb/test/CMakeLists.txt b/lldb/test/CMakeLists.txt
index 6fb8235907c..7ca9b1bdd84 100644
--- a/lldb/test/CMakeLists.txt
+++ b/lldb/test/CMakeLists.txt
@@ -34,6 +34,10 @@ if(TARGET lldb-mi)
list(APPEND LLDB_TEST_DEPS lldb-mi)
endif()
+if(NOT LLDB_BUILT_STANDALONE)
+ list(APPEND LLDB_TEST_DEPS yaml2obj)
+endif()
+
# The default architecture with which to compile test executables is the default LLVM target
# architecture, which itself defaults to the host architecture.
string(TOLOWER "${LLVM_TARGET_ARCH}" LLDB_DEFAULT_TEST_ARCH)
OpenPOWER on IntegriCloud