summaryrefslogtreecommitdiffstats
path: root/compiler-rt/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2012-11-16 12:57:07 +0000
committerAlexey Samsonov <samsonov@google.com>2012-11-16 12:57:07 +0000
commitbe9a293ddaa763b33340f3adb53da80cdb950d58 (patch)
tree28dde61765cb9bd74689c4fbe35ef42d5c5b1225 /compiler-rt/lib/CMakeLists.txt
parentcc42980335a44643ce8e79c7092446581ef457c8 (diff)
downloadbcm5719-llvm-be9a293ddaa763b33340f3adb53da80cdb950d58.tar.gz
bcm5719-llvm-be9a293ddaa763b33340f3adb53da80cdb950d58.zip
UBSan: enable CMake build on Darwin. Fix two failing tests and disable the test which produces linker errors on Darwin.
llvm-svn: 168169
Diffstat (limited to 'compiler-rt/lib/CMakeLists.txt')
-rw-r--r--compiler-rt/lib/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/compiler-rt/lib/CMakeLists.txt b/compiler-rt/lib/CMakeLists.txt
index 6febaf54c6d..b7cd07ee21b 100644
--- a/compiler-rt/lib/CMakeLists.txt
+++ b/compiler-rt/lib/CMakeLists.txt
@@ -6,12 +6,11 @@ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux")
add_subdirectory(asan)
add_subdirectory(interception)
add_subdirectory(sanitizer_common)
+ add_subdirectory(ubsan)
endif()
if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
# ThreadSanitizer is supported on Linux only.
add_subdirectory(tsan)
- # UndefinedBehaviorSanitizer has been tested on Linux only.
- add_subdirectory(ubsan)
endif()
# FIXME: Add support for the profile library.
OpenPOWER on IntegriCloud