summaryrefslogtreecommitdiffstats
path: root/clang/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Lorenz <arphaman@gmail.com>2017-07-21 12:49:28 +0000
committerAlex Lorenz <arphaman@gmail.com>2017-07-21 12:49:28 +0000
commita75b2cac718500b6b0d2bc59abc7ccbb1eeb0663 (patch)
tree467caac864825052c987965ddadba416031a5a40 /clang/tools/CMakeLists.txt
parent024e319489daa7fe28e0d639502f2f141fb5a146 (diff)
downloadbcm5719-llvm-a75b2cac718500b6b0d2bc59abc7ccbb1eeb0663.tar.gz
bcm5719-llvm-a75b2cac718500b6b0d2bc59abc7ccbb1eeb0663.zip
[clang-diff] Add initial implementation
This is the first commit for the "Clang-based C/C++ diff tool" GSoC project. ASTDiff is a new library that computes a structural AST diff between two ASTs using the gumtree algorithm. Clang-diff is a new Clang tool that will show the structural code changes between different ASTs. Patch by Johannes Altmanninger! Differential Revision: https://reviews.llvm.org/D34329 llvm-svn: 308731
Diffstat (limited to 'clang/tools/CMakeLists.txt')
-rw-r--r--clang/tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/tools/CMakeLists.txt b/clang/tools/CMakeLists.txt
index 4976332b7db..17ad9f4a1a1 100644
--- a/clang/tools/CMakeLists.txt
+++ b/clang/tools/CMakeLists.txt
@@ -2,6 +2,7 @@ create_subdirectory_options(CLANG TOOL)
add_clang_subdirectory(diagtool)
add_clang_subdirectory(driver)
+add_clang_subdirectory(clang-diff)
add_clang_subdirectory(clang-format)
add_clang_subdirectory(clang-format-vs)
add_clang_subdirectory(clang-fuzzer)
OpenPOWER on IntegriCloud